IT WON'T LOAD!

I've been trying to play tombquest for several DAYS now, but whenever I try to build or invade a tomb, it just keeps loading and loading and loading and loading and loading! While I haven't been on, a bunch of people have invaded my tomb and stolen all my treasure! And there was nothing I could do about it! IT IS SO INFURIATING AND FRUSTRATING! Help! 

  • Posted at:

Please tell us why you'd like to report this post

Plz don't send me friend requests: I can only take clan requests, and I feel bad denying requests.

 

UAC

 

I'm Autumn, Alexa, or Amberturtle

#GOFNF!

1st post on SAMB: 7/12/2014

 

#RememberLeia

 

#RememberAtlantis

 

J+E

 

*..yep, I did it on Creative.. :P      

Mods, it would be appreciated if you could respond on this thread. I'd like to know why tombquest isn't working...it's really annoying, and if it's a bug, could you please fix it?

  • Posted at:

Please tell us why you'd like to report this post

Plz don't send me friend requests: I can only take clan requests, and I feel bad denying requests.

 

UAC

 

I'm Autumn, Alexa, or Amberturtle

#GOFNF!

1st post on SAMB: 7/12/2014

 

#RememberLeia

 

#RememberAtlantis

 

J+E

 

*..yep, I did it on Creative.. :P      

Use the Feedback/Report A Bug button. It goes directly to the game designers, and it's a lot more reliable than the forum.

  • Posted at:

Please tell us why you'd like to report this post

If you can be sad, you can be glad, and that's how I chose to be. - Winter D. P.

 

Queen of Winter and Coqueen of DRAGONS!

 

I HAVE RETURNED FROM THE NETHER EXISTENCE! Greetings. <(^_^<)